Continued registration performance issues
Incident Report for Veracross
Postmortem

See updates and information here.

Posted Aug 16, 2019 - 22:32 EDT

Resolved
The issues affecting program registration performance have been resolved. We will continue to monitor the situation and provide updates as necessary. Thank you for your patience.
Posted Aug 16, 2019 - 22:13 EDT
Monitoring
While program registration functionality has been restored, we continue to receive reports of slow performance and are investigating. We will provide updates as they become available. Thank you for your patience.
Posted Aug 16, 2019 - 07:44 EDT