Continued Axiom Performance Issues
Incident Report for Veracross
Resolved
Axiom performance issues have been resolved. We will continue to monitor the situation and provide additional status updates as required. Thank you for your patience.
Posted Jul 21, 2020 - 14:32 EDT
Monitoring
We continue to monitor Axiom performance issues. We will provide updates as they become available.
Posted Jul 21, 2020 - 13:43 EDT
This incident affected: Axiom US and Axiom EU.