Email composer availability
Incident Report for Veracross
Resolved
At approximately 1430 EDT (1830 UTC) servers supporting US-based email composer functionality became unavailable. Veracross engineers were alerted to the issue nearly immediately. The servers were replaced, and functionality was restored by 1450 EDT (1850 UTC). We will provide additional updates as necessary. Thank you for your patience.
Posted Aug 06, 2019 - 14:53 EDT
Investigating
We are currently investigating an issue with email composer availability in the US. We will provide updates as they become available.
Posted Aug 06, 2019 - 14:37 EDT