Scheduler US Partial Outage
Incident Report for Veracross
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 23:01 EST
Investigating
We have detected a partial outage for Scheduler in the US.
Posted Feb 11, 2020 - 22:52 EST
This incident affected: US (Scheduler US).