Degraded performance for certain Axiom functionality
Incident Report for Veracross
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 12:17 EST
Investigating
We are currently investigating an issue affecting certain Axiom functionality. Note this affects certain Email functionality as well. We will provide updates as they become available.
Posted Mar 05, 2021 - 11:50 EST
This incident affected: Axiom US, Axiom EU and Common (Email & SMS).