Continued Issues with Some System Emails
Incident Report for Veracross
Resolved
This incident has been resolved. We apologize for the disruption and thank you for your patience.
Posted May 31, 2023 - 13:58 EDT
Investigating
We are investigating additional reports of continued issues with some system emails not sending. We will provide additional details as soon as we have more information to share. Thank you for your patience.
Posted May 31, 2023 - 12:39 EDT
This incident affected: Common (Email & SMS).