Issue preventing some system emails from sending successfully

Incident Report for Veracross

Resolved

We have identified and resolved an issue that was preventing some system emails from being delivered over the last few days. All queued emails have now been sent. We apologize for this disruption.
Posted May 31, 2023 - 08:45 EDT