Payment Processing
Incident Report for Veracross
Resolved
This issue has been resolved by our payment processor. Thank you for your patience.
Posted Feb 12, 2020 - 09:50 EST
Investigating
Our primary payment processing partner is currently experiencing a network issue which is preventing Veracross users from completing transactions. We are monitoring the situation and investigating possible workarounds. We will provide updates here as they are available.
Posted Feb 12, 2020 - 08:36 EST
This incident affected: EU (Payments EU) and US (Payments US).