Data Importer Issue

Incident Report for Veracross

Resolved

This incident has been resolved. We apologize for the disruption.
Posted Aug 12, 2026 - 12:11 EDT

Investigating

We are currently investigating reports that Data Importer imports are stuck in pending status.
Posted Aug 12, 2026 - 11:51 EDT
This incident affected: Common (Importer).