Issue with Time Display in Axiom

Incident Report for Veracross

Resolved

This incident has been resolved and each database is now displaying time correctly using the school's time zone.
Posted Aug 27, 2026 - 18:54 EDT

Investigating

We are currently investigating an issue with the time display in Axiom incorrectly using UTC rather than the school's actual time zone.
Posted Aug 27, 2026 - 17:39 EDT
This incident affected: Axiom US, Axiom EU, and Axiom AU.