Issue with MFA Verification Emails

Incident Report for Veracross

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 12:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 11:11 EDT

Identified

We have identified the issue and determined that this is impacting a subset of users. We are working to implement a fix. In the meantime, instructions for changing the MFA authentication method can be found here: https://community.veracross.com/s/article/How-do-I-change-my-MFA-authentication-method
Posted Oct 24, 2025 - 09:45 EDT

Investigating

We are currently investigating reports that MFA verification codes are not being received by recipients.
Posted Oct 24, 2025 - 09:17 EDT
This incident affected: US (Authentication & User Accounts US).