Issues with Grade Review Process
Incident Report for Veracross
Resolved
We have identified and resolved the issue. Thank you for your patience.
Posted Nov 30, 2022 - 16:27 EST
Investigating
We are currently investigating issues affecting the Grade Review process in Axiom and the Faculty Portal. We will provide an update as soon as we are able.
Posted Nov 30, 2022 - 16:08 EST