Email Delivery Delays for a Subset of Customers

Incident Report for Veracross

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 12:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 11:13 EDT

Investigating

We are investigating an issue causing email delivery delays for a subset of customers.
Posted Oct 24, 2025 - 09:52 EDT
This incident affected: Common (Email & SMS).