Axiom Performance Issues affecting Subset of Users
Incident Report for Veracross
Resolved
We identified and resolved an issue that was affecting Axiom performance for a subset of users. Thank you for your patience.
Posted Nov 23, 2021 - 11:13 EST
Investigating
We are currently investigating Axiom performance issues for a subset of users. We will provide additional updates as soon as we have more information to share.
Posted Nov 23, 2021 - 10:49 EST
This incident affected: Axiom US.