App Availability
Incident Report for Veracross
Resolved
This is resolved. We apologize the inconvenience.
Posted Aug 06, 2018 - 10:40 EDT
Identified
We've identified a problem causing most apps to be unavailable. We will have it fixed shortly.
Posted Aug 06, 2018 - 10:32 EDT