Continued Axiom availability issues
Incident Report for Veracross
Resolved
We have identified and resolved the underlying issue affecting Axiom.
Posted Aug 03, 2020 - 11:21 EDT
Investigating
We continue to investigate problems affecting Axiom availability.
Posted Aug 03, 2020 - 11:04 EDT
This incident affected: Axiom US.