Class website availability
Incident Report for Veracross
Resolved
The issue affecting class websites has been resolved. We will provide any additional updates if necessary. Thank you for your patience.
Posted Aug 08, 2019 - 16:20 EDT
Investigating
We are currently looking into an issue preventing class websites from being displayed. We will provide updates as they become available. Thank you for your patience.
Posted Aug 08, 2019 - 13:38 EDT