Admissions 2.0 & Enrollment issue
Incident Report for Veracross
Resolved
We have resolved the issues affecting Admissions 2.0 & Enrollment. Thank you for your patience.
Posted May 22, 2020 - 15:01 EDT
Update
We continue to address the Admissions 2.0 & Enrollment issues. Thank you for your patience.
Posted May 22, 2020 - 13:20 EDT
Identified
We have identified an issue affecting Admissions 2.0 & Enrollment and are implementing a fix. During this time, the application may become unavailable for some schools.
Posted May 22, 2020 - 13:11 EDT
This incident affected: Common (Admissions 2.0 & Enrollment).