Admission Portal File Upload Issue
Incident Report for Veracross
Resolved
This issue has been resolved and files should now upload successfully in the Admission Portal. We apologize for any inconvenience this caused!
Posted Mar 05, 2019 - 12:28 EST
Investigating
We are investigating an issue with file uploads in the Admission Portal.
Posted Mar 05, 2019 - 08:06 EST